Fredag, 20 april 2012 10:04

Opdatering (migration) fra Joomla fra 1,5 til 2,5

Skrevet af 

Joomla 1.5 er ved at nå til vejs ende og vil snart ikke blive opdateret længere. Den nye version af Joomla - Joomla 2.5 - er i samme ombæring gået hen og blevet rigtig god og det er derfor min, og mange andres, anbefaling at du bør overveje om det ikke er på tide at få opdateret din Joomla installation.

Lad mig fra start understrege, at det ikke er livstruende nødvendigt du opgraderer endnu: Joomla 1.5 er meget kraftfuldt og veludviklet og 1.5 vil blive supporteret nogle måneder endnu. Men er du seriøs omkring dit website - og har tænkt dig det skal leve mange år endnu - så vil du alligevel komme til at opgradere på et tidspunkt. Så hvorfor ikke tage tyren ved hornene og få gjort det nu?

Hvad skal du sikre dig, før du opdaterer fra 1.5 til 2.5?

Før du starter din opdatering, er her lige et par ting, du skal tjekke og overveje:

Er din server klar til joomla 2.5?

Gør mig den tjeneste, at tjekke om dit dit servermiljø kan køre Joomla 2.5, inden du begynder at opgradere. Herunder linker jeg til en kravsliste for at Joomla 2.5 kan køre. Er du i tvivl om din server lever op til kravene, så ring til din hostingudbyder og spørg. De burde kunne svare dig på det.

  • Tekniske krav til Joomla 2.5
  • Krav til komponentet jUpgrade, som vi skal bruge til at migrere dit site til 2.5
  • Er din Joomla 1.5 installation opdateret til nyeste version?

    Hvis ikke, så bør du starte med at opgradere til 1.5.25. Dette gælder især, hvis du bruger Joomla 1.511 eller ældre.

  • Engelsk guide til at opgradere joomla 1.5 til nyeste version
  • Findes de udvidelser du bruger i en Joomla 2.5 version?

    Det er desværre ikke alle udvidelser, der er opdateret til Joomla 2.5 version endnu. Derfor vil de ikke virke efter du har migreret dit site til 2.5. Vær opmærksom på at fordi der har været en mellemtidsperiode med Joomla 1.6 og 1.7, så vil mange komponenter være markeret som brugbare til disse version: Når et komponent er markeret til at virke til 1.6 eller 1.7, så vil det også virke i 2.5

    Er dit template opdateret til 2.5?

    Der er blevet lavet en række grundlæggende ændringer i Joomla template-strukturen, der gør at Joomla 1.5 templates ikke kan bruges til 2.5. Find derfor ud af om det template du bruger findes i en nyere version og hvis ikke, så spørg dig selv om du er klar til at lave disse ændringer manuelt? Ændringerne, der skal laves, er ikke voldsomme, men det kræver unægteligt en god forståelse for programmering, før du manuelt kan gå ind og opdatere et template

  • Guide til at opdatere dit template til 2.5

  • Opdatering af Joomla – Trin for trin

    Når du har gennemgået og tænkt over de ovenstående ting, er du klar til at migrere til den nyeste version. Let’s get going

    Trin 1: Backup – og lad nu være med at springe dette skridt over!

    Du må aldrig begynde at lege med din Joomla Installationuden at have backup.

    Jeg vil klart anbefale at du bruger komponentet ”ba backup” til at tage en backup at hele dit system. Det er nemt at bruge og virker perfekt for langt de fleste.

  • Download akeeba backup
  • Er du medlem af Joomla Skolen kan du finde en række videoer, der viser dig præcist hvordan du gør:

  • Akeeba backup – dansk videoguide
  • HUSK NU AT TAGE DEN BACKUP

    Trin 2: Hent og installer komponentet ”jUpgrade”

    Efter du har taget en backup af dit site, downloadet den og lagt den et sikkert sted, er det tid til at hente det komponent, du skal bruge til at migrere Joomla til 2.5. Komponentet hedder – som nævnt – jUpgrade og kan hentes her:

  • Download jUpgrade komponentet
  • Efter du har hentet komponentet installerer du det blot som alle andre Joomla-komponenter. Når du har det installeret er du ved at være klar til at lave opdateringen.... spændende, ik?

    Trin 3: Opgradering af Joomla med jUpgrade

    Nu skal vi bruge jUpgrade til at migrere til nyeste version af Joomla. Følg disse lette trin:

  • Gå op i komponenter/components og vælg ”jUpgrade”
  • Klik på ”START UPGRADE
  • Lad komponentet processe opgraderingen.

  • Gør INTET før du ser ”Joomla 1.7 Upgrade finished” (se billedet - -bemærk dog billedet er af ældre version, så der står 1.7 i stedet for 2.5)
  • Nu burde du være opdateret til nyeste version.
  • Men lad os lige tjekke om det er som det skal være...

    Tjek om opgraderingen af Joomla er som den skal være

    Som med alt andet it-relateret kan der jo gå noget galt i en sådan update. Også uden at Joomla nødvendigvis gør dig opmærksom på det. Gør derfor dig selv den tjeneste at tjekke følgende om alt på dit website virker som det skal

    Engelsk, der viser dig hele Joomla opgraderingsprocessen:

    Herunder kan du se en video, der viser dig alle disse skridt. Videoen er dog af lidt ældre dato, så der vil stå Joomla 1.6 i stedet for 2.5.. men processen er den samme

    Brug for professionel hjælp?

    Synes du opdateringen er for svær selv at lave? Hiv endelig fat i os, så kommer vi med et uforpligtende tilbud på opdatering af din hjemmeside. RING 51 93 70 17


    Læst 31394 gange Senest ændret Mandag, 23 april 2012 13:44

    6 kommentarer

    • Kommentar link Rasmus Hoeks Tirsdag, 14 august 2012 10:40 Skrevet af Rasmus Hoeks

      @Morten:

      Vi krydser fingre

      Husk for guds skyld at holde styr på dine url'er. Hvis du ændrer på dem, så kan du smadre alt dit gode arbejde i søgemaskinerne. Det er virkeligt vigtigt, du holder tungen ligei munden. Især når sitet er så stort som dit.

    • Kommentar link Morten Høy Søndag, 12 august 2012 10:49 Skrevet af Morten Høy

      Så er tiden inde til at jeg skal opdatere mit websted...kryds fingre, for jeg er sgu lidt nervøs, da jeg ikke har prøvet det før. jeg vil starte med at finde alle udvidelser og moduler, og rigtig fed guide det her....

    • Kommentar link Rasmus Hoeks Mandag, 14 maj 2012 12:43 Skrevet af Rasmus Hoeks

      Hej folkens
      Vil i ikke stille spørgsmålene i vores forum i stedet - så er der flere, der ser dem og så kan vi også bedre holde de forskellige problemstillinger fra hinanden, så spørgsmålene kan blive besvaret en efter en.

      Tak.

    • Kommentar link Søren Weiss Søndag, 13 maj 2012 14:48 Skrevet af Søren Weiss

      Hej Rasmus... jeg prøver først at opdatere min version 1.5.23 til 1.5.26 men hver gang jeg forsøger at installere kommer denne besked "Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 20129752 bytes) in /mounted-storage/home111a/sub005/sc65885-OGAY/www/libraries/joomla/filesystem/archive/gzip.php on line 77" - hvad kan jeg gøre ved det?? Hilsner Søren

    • Kommentar link Chris Mandag, 23 april 2012 18:55 Skrevet af Chris

      Hi
      Hvordan ser jeg de logs som jupdate kommer med, hvor er de ?
      Har prøvet nu 3 gange, uden at den kommer videre, så der må ligge nogle logs, som jeg kan gu ud fra ?
      Lad høre fra dig.
      Med virusfri hilsen

    • Kommentar link sanne Mandag, 23 april 2012 15:30 Skrevet af sanne

      Hej Rasmus
      Nu spørger jeg måske lidt dumt, men det fremgår ikke af din ellers udførlige instruktion, om man også skal installere alle komponenter og udvidelser forfra, eller om den trækker det med over? (Jeg ved godt at de muligvis ligger som 1.5 komponenter på mit nuværende websted, men hvis den trækker dem med over, kan man måske opgradere fra 2.5 udgaven??)
      Hvad med alle de artikler osv. man har - kommer de også automatisk med over?
      Faktisk er det derfor jeg er lidt usikker på, om jeg skal opgradere til 2.5 - for det bliver jo et kæmpe arbejde, hvis man nærmest skal starte helt forfra med det hele.
      mange hilsner fra møjn-land

    Skriv en kommentar

    Sørg for du indtaster de påkrævede oplysninger (*).
    HTML kode er ikke tilladt.